我的VPS上安装的WDCP面板,本来一切正常,但某日准备安装PHPBB3最新版时出现错误,搜索发现是php版本太低,PHPBB要求5.3以上,而wdcp自带的是5.2.x,于是需要升级。

按以下步骤成功:

1、下载并执行一键升级脚本

wget http://soft.itbulu.com/wdcp/php_up55.sh
sh  php_up55.sh

或者从这里下载并上传执行php_up55.zip

 

2、下载以及运行PHP5.5,看到下面的界面,我们需要输入y确认开始安装。

3、安装过程比较久,时间依据网络和VPS性能决定,我的进行了大概10分钟。

出现上面界面表示安装成功。

 

4、可以在php信息页面查看php版本号。完成后建议重启服务器或服务。